$re = '/^[A-Z\x{C0}-\x{2AF}\'"\s-]+$/sumi';
$str = 'Fred
T3d
Björg
Shawn\'iq\'ua
Åbjørn
Mary-Jane
Æstrid
will.i.am';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);