using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z\x{C0}-\x{2AF}'""\s-]+$";
string input = @"Fred
T3d
Björg
Shawn'iq'ua
Åbjørn
Mary-Jane
Æstrid
will.i.am";
RegexOptions options = RegexOptions.Singleline | RegexOptions.CultureInvariant | RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}