re = /^[A-Z\x{C0}-\x{2AF}'"\s-]+$/mi
str = 'Fred
T3d
Björg
Shawn\'iq\'ua
Åbjørn
Mary-Jane
Æstrid
will.i.am'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end