#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?:is|isolated|somethingElse)\b"
Local $sString = "this is isolated is an example of this and that"
Local $sSubst = "#$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)