import re
regex = re.compile(r"\b(?:is|isolated|somethingElse)\b")
test_str = "this is isolated is an example of this and that"
subst = "#$0"
result = regex.sub(subst, test_str)
if result:
print(result)