use strict;
my $str = 'this is isolated is an example of this and that';
my $regex = qr~\b(?:is|isolated|somethingElse)\b~p;
my $subst = '#$0';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";