using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:is|isolated|somethingElse)\b";
string substitution = @"#$0";
string input = @"this is isolated is an example of this and that";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}