$re = '~\b(?:is|isolated|somethingElse)\b~';
$str = 'this is isolated is an example of this and that';
$subst = "#$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;