const regex = new RegExp('\\b(?:is|isolated|somethingElse)\\b', 'g')
const str = `this is isolated is an example of this and that`;
const subst = `#$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);