const regex = new RegExp('from=doggerino@gmail.co(?!\\S)', 'g')
const str = `from=doggerino@gmail.com sender=yessss
from=doggerino@gmail.co sender=yessss
sender=yaaas from=doggerino@gmail.co subject=yaaas
sender=yaaas from=doggerino@gmail.com subject=yaaas
sender=yaaas from=doggerino@gmail.com
sender=yaaas from=doggerino@gmail.co
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}