import re
regex = re.compile(r"from=doggerino@gmail.co(?!\S)")
test_str = ("from=doggerino@gmail.com sender=yessss\n"
"from=doggerino@gmail.co sender=yessss\n"
"sender=yaaas from=doggerino@gmail.co subject=yaaas\n"
"sender=yaaas from=doggerino@gmail.com subject=yaaas\n"
"sender=yaaas from=doggerino@gmail.com\n"
"sender=yaaas from=doggerino@gmail.co\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")