re = /from=doggerino@gmail.co(?!\S)/
str = 'from=doggerino@gmail.com sender=yessss
from=doggerino@gmail.co sender=yessss
sender=yaaas from=doggerino@gmail.co subject=yaaas
sender=yaaas from=doggerino@gmail.com subject=yaaas
sender=yaaas from=doggerino@gmail.com
sender=yaaas from=doggerino@gmail.co
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end