import Foundation
let pattern = #"from=doggerino@gmail.co(?!\S)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
from=doggerino@gmail.com sender=yessss
from=doggerino@gmail.co sender=yessss
sender=yaaas from=doggerino@gmail.co subject=yaaas
sender=yaaas from=doggerino@gmail.com subject=yaaas
sender=yaaas from=doggerino@gmail.com
sender=yaaas from=doggerino@gmail.co
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)