$re = '/from=doggerino@gmail.co(?!\S)/';
$str = 'from=doggerino@gmail.com sender=yessss
from=doggerino@gmail.co sender=yessss
sender=yaaas from=doggerino@gmail.co subject=yaaas
sender=yaaas from=doggerino@gmail.com subject=yaaas
sender=yaaas from=doggerino@gmail.com
sender=yaaas from=doggerino@gmail.co
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);