using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<(?:input)[\s\S]*?({{variable:system_version}})[\s\S]*?>$";
string input = @"<input value=""System version: {{variable:system_version}}"">
<input value=""System version: 6"">
<input value=""System version: 6"">";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}