$re = '/^<(?:input)[\s\S]*?({{variable:system_version}})[\s\S]*?>$/im';
$str = '<input value="System version: {{variable:system_version}}">
<input value="System version: 6">
<input value="System version: 6">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);