const regex = /^<(?:input)[\s\S]*?({{variable:system_version}})[\s\S]*?>$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^<(?:input)[\\s\\S]*?({{variable:system_version}})[\\s\\S]*?>$', 'img')
const str = `<input value="System version: {{variable:system_version}}">
<input value="System version: 6">
<input value="System version: 6">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}