re = /^<(?:input)[\s\S]*?({{variable:system_version}})[\s\S]*?>$/im
str = '<input value="System version: {{variable:system_version}}">
<input value="System version: 6">
<input value="System version: 6">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end