import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<(?:input)[\\s\\S]*?(\\{\\{variable:system_version\\}\\})[\\s\\S]*?>$";
final String string = "<input value=\"System version: {{variable:system_version}}\">\n"
+ "<input value=\"System version: 6\">\n"
+ "<input value=\"System version: 6\">";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}