# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^-[^\n]*\n\h+|(?!^)\G)([^\n]*)\n(?!-)\h+/$1$2 /gm;t' <<< " abc
def
- test 1
test test test
test test test
test test test
- test2
- test3
test test t
test test test
- test 4
test test test
- test5"