import re
regex = re.compile(r"(^-[^\n]*\n\h+|(?!^)\G)([^\n]*)\n(?!-)\h+", flags=re.MULTILINE)
test_str = (" abc\n"
" def\n"
"- test 1\n"
" test test test\n"
" test test test\n"
" test test test\n"
"- test2\n"
"- test3\n"
" test test t\n"
" test test test\n"
"- test 4\n"
" test test test\n"
"- test5")
subst = "$1$2 "
result = regex.sub(subst, test_str)
if result:
print(result)