#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^-[^\n]*\n\h+|(?!^)\G)([^\n]*)\n(?!-)\h+"
Local $sString = " abc" & @CRLF & _
" def" & @CRLF & _
"- test 1" & @CRLF & _
" test test test" & @CRLF & _
" test test test" & @CRLF & _
" test test test" & @CRLF & _
"- test2" & @CRLF & _
"- test3" & @CRLF & _
" test test t" & @CRLF & _
" test test test" & @CRLF & _
"- test 4" & @CRLF & _
" test test test" & @CRLF & _
"- test5"
Local $sSubst = "$1$2 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)