re = /(^-[^\n]*\n\h+|(?!^)\G)([^\n]*)\n(?!-)\h+/m
str = ' abc
def
- test 1
test test test
test test test
test test test
- test2
- test3
test test t
test test test
- test 4
test test test
- test5'
subst = '$1$2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result