import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^-[^\\n]*\\n\\h+|(?!^)\\G)([^\\n]*)\\n(?!-)\\h+";
final String string = " abc\n"
+ " def\n"
+ "- test 1\n"
+ " test test test\n"
+ " test test test\n"
+ " test test test\n"
+ "- test2\n"
+ "- test3\n"
+ " test test t\n"
+ " test test test\n"
+ "- test 4\n"
+ " test test test\n"
+ "- test5";
final String subst = "$1$2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}