use strict;
my $str = ' abc
def
- test 1
test test test
test test test
test test test
- test2
- test3
test test t
test test test
- test 4
test test test
- test5';
my $regex = qr/(^-[^\n]*\n\h+|(?!^)\G)([^\n]*)\n(?!-)\h+/mp;
my $subst = '$1$2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";