#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+-]?JPY.*?(?=~)"
Local $sString = "EUR 25,963.00" & @CRLF & _
"EUR 26,020.50" & @CRLF & _
"-JPY 20,365.00 " & @CRLF & _
"-HKD 29,996.00" & @CRLF & _
"JPY 21,295.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")