using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?JPY.*?(?=~)";
string input = @"EUR 25,963.00
EUR 26,020.50
-JPY 20,365.00
-HKD 29,996.00
JPY 21,295.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}