const regex = /[+-]?JPY.*?(?=~)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+-]?JPY.*?(?=~)', 'gm')
const str = `EUR 25,963.00
EUR 26,020.50
-JPY 20,365.00
-HKD 29,996.00
JPY 21,295.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}