re = /[+-]?JPY.*?(?=~)/m
str = 'EUR 25,963.00
EUR 26,020.50
-JPY 20,365.00
-HKD 29,996.00
JPY 21,295.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end