import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[+-]?JPY.*?(?=~)";
final String string = "EUR 25,963.00\n"
+ "EUR 26,020.50\n"
+ "-JPY 20,365.00 \n"
+ "-HKD 29,996.00\n"
+ "JPY 21,295.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}