$re = '/[+-]?JPY.*?(?=~)/m';
$str = 'EUR 25,963.00
EUR 26,020.50
-JPY 20,365.00
-HKD 29,996.00
JPY 21,295.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);