using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^if TYPE_CHECKING:(?:\n\s*from .*)*";
string input = @"if TYPE_CHECKING:
from foo import bar
from x import y
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}