// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^if TYPE_CHECKING:(?:\n\s*from .*)*").unwrap();
let string = "if TYPE_CHECKING:
from foo import bar
from x import y
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}