import re
regex = re.compile(r"^if TYPE_CHECKING:(?:\n\s*from .*)*", flags=re.MULTILINE)
test_str = ("if TYPE_CHECKING:\n"
" from foo import bar\n"
" from x import y\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")