re = /^if TYPE_CHECKING:(?:\n\s*from .*)*/m
str = 'if TYPE_CHECKING:
from foo import bar
from x import y
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end