using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=(?:""[^""]*""|'[^']*')|([.,])";
string input = @"test . <a id="" href=""."">test</a> test <a href=""test"" class=""></a> test with a . dot here
href=""text.test"" test . test, test href='test'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}