// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)href=(?:"[^"]*"|'[^']*')|([.,])"#).unwrap();
let string = "test . <a id=\"\" href=\".\">test</a> test <a href=\"test\" class=\"\"></a> test with a . dot here
href=\"text.test\" test . test, test href='test'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}