re = /href=(?:"[^"]*"|'[^']*')|([.,])/m
str = 'test . <a id="" href=".">test</a> test <a href="test" class=""></a> test with a . dot here
href="text.test" test . test, test href=\'test\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end