const regex = /href=(?:"[^"]*"|'[^']*')|([.,])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=(?:"[^"]*"|\'[^\']*\')|([.,])', 'gm')
const str = `test . <a id="" href=".">test</a> test <a href="test" class=""></a> test with a . dot here
href="text.test" test . test, test href='test'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}