package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)href=(?:"[^"]*"|'[^']*')|([.,])`)
var str = `test . <a id="" href=".">test</a> test <a href="test" class=""></a> test with a . dot here
href="text.test" test . test, test href='test'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}