using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[AB]\d+|[XY])+$";
string input = @"A11X
A45YA1X
A1XXA999YYA1
A1A1AAX12
1A1Y32A1
CA1A1
A1C1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}