$re = '/^(?:[AB]\d+|[XY])+$/m';
$str = 'A11X
A45YA1X
A1XXA999YYA1
A1A1AAX12
1A1Y32A1
CA1A1
A1C1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);