package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[AB]\d+|[XY])+$`)
var str = `A11X
A45YA1X
A1XXA999YYA1
A1A1AAX12
1A1Y32A1
CA1A1
A1C1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}