const regex = /^(?:[AB]\d+|[XY])+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[AB]\\d+|[XY])+$', 'gm')
const str = `A11X
A45YA1X
A1XXA999YYA1
A1A1AAX12
1A1Y32A1
CA1A1
A1C1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}