import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[AB]\\d+|[XY])+$";
final String string = "A11X\n"
+ "A45YA1X\n"
+ "A1XXA999YYA1\n\n"
+ "A1A1AAX12\n"
+ "1A1Y32A1\n"
+ "CA1A1\n"
+ "A1C1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}