re = /^(?:[AB]\d+|[XY])+$/m
str = 'A11X
A45YA1X
A1XXA999YYA1
A1A1AAX12
1A1Y32A1
CA1A1
A1C1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end