#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"fields":{(?<fields>[\w\W]+?)}"
Local $sString = "{"records":[{"id":"recrsBYQ","createdTime":"2024-09-06T10:22:21.000Z","fields":{"fields1":"xyz","fields2":true}},{"id":"rec123XYZ","createdTime":"2024-09-07T12:00:00.000Z","fields":{"fields1":"abc","fields2":false}}]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")