// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"fields":{(?<fields>[\w\W]+?)}"#).unwrap();
let string = "{\"records\":[{\"id\":\"recrsBYQ\",\"createdTime\":\"2024-09-06T10:22:21.000Z\",\"fields\":{\"fields1\":\"xyz\",\"fields2\":true}},{\"id\":\"rec123XYZ\",\"createdTime\":\"2024-09-07T12:00:00.000Z\",\"fields\":{\"fields1\":\"abc\",\"fields2\":false}}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}