import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"fields\":\\{(?<fields>[\\w\\W]+?)\\}";
final String string = "{\"records\":[{\"id\":\"recrsBYQ\",\"createdTime\":\"2024-09-06T10:22:21.000Z\",\"fields\":{\"fields1\":\"xyz\",\"fields2\":true}},{\"id\":\"rec123XYZ\",\"createdTime\":\"2024-09-07T12:00:00.000Z\",\"fields\":{\"fields1\":\"abc\",\"fields2\":false}}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}