const regex = /"fields":{(?<fields>[\w\W]+?)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"fields":{(?<fields>[\\w\\W]+?)}', 'gm')
const str = `{"records":[{"id":"recrsBYQ","createdTime":"2024-09-06T10:22:21.000Z","fields":{"fields1":"xyz","fields2":true}},{"id":"rec123XYZ","createdTime":"2024-09-07T12:00:00.000Z","fields":{"fields1":"abc","fields2":false}}]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}